Railsで使えるGem

Railsでjavascriptやcoffeescriptをつかうとき便利かもしれないGem

投稿日:

oj

github.com/ohler55/oj

JSONの替わりに使ったOJが速い

高速なJSONパーサ

 

gon

github.com/gazay/gon

Railsの変数をJavascript内で使えるようにする

RailsからJavaScriptにデータを渡す

 

js-routes

github.com/railsware/js-routes/

Javascriptの中からnamed routeを使えるよ

article_pathとかそういうのがJavascript内で使えるようになる

 

rails-dev-tweaks

github.com/wavii/rails-dev-tweaks

Sass、Compass、Rails 3.1 のアセット パイプライン (翻訳版)

「この gem には Rails の自動読み込み規則を変更する機能があるので、開発中の各要求間の再読み込みが回避されます。既定の規則では、アセット、XHR、および favicon 要求でのクラスの再読み込みをスキップします」

-Railsで使えるGem
-,

執筆者:

関連記事

no image

Rails4とPostreSQL9.3で全文検索〜pg_bigm

目次1 準備2 migration3  使い方 準備 エクステンションを導入しておく Ubuntu Server12.04でPostgreSQL9.3をつかう〜pg_bigmで全文検索 migrati …

Rails4.1に対応したRefinery CMS 3.0を試してみた

By: Alexis Madrigal – CC BY 2.0 目次1 Refinery CMS2 Gemfile3 generate4 configファイル5 起動6 管理画面7 トラブ …

RailsにTwitter Bootstrapを設定する~twitter-bootstrap-rails

環境 ruby 1.9.3  & rails 3.2.8 適当なscaffoldを作っておく

  github.co …

Rails3.2.8でテーブル並び替えのテストを作る~cucumberと正規表現

前提 Railsのテーブル並び替えを実装する Rails3.2.8で自動テスト環境を整える〜cucumber+spork+guard 目次1 作戦(ストラテジー)2 have_contentの正規表現 …

RailsでHTML5対応のvideoプレイヤーを利用してみる~flowplayer5.0.0

  参考 flowplayer.org/ Flowplayerのサイトからバージョン5.0.0がダウンロードできる flowplayer-gemのバージョンは3.2.4 バージョン5では基本 …