node.js

Ubuntu12.04にnode6.9をインストール~nodebrew

投稿日:

nodebrew自身のアップデート

インストールできるパッケージを確認.

nodebrewでnode6.9をインストール

しかし、エラーがずらっと..

エラーでググってみると、ubuntu12.04では、gccとg++のバージョンが古くてエラーが出るらしい.
4.2.0 and 4.2.1 errors out on ubuntu 12.04 #74

リンク先のとおり、gccとg++のバージョンをあげてみる.

と、コンパイルが通った!

yarnのインストール

ついでに、話題のパッケージマネージャyarnをインストール.
めちゃ早くて、チョー安全で、バリ頼れるできるらしい.

-node.js
-,

執筆者:

関連記事

no image

socket.ioでリアルタイムチャット

目次1 環境2 準備3 サーバー側~express4 socket.ioのイベント駆動5 サーバー側~socket.io6 クライアント側7  接続者全員にメッセージを流したいので修正8  情報 環境 …

Electronでsql.js

By: Dmitry Baranovskiy – CC BY 2.0 目次1 sql.js2 準備3 インストール4 main.coffee5 index.coffee6 index.ht …

Todolistをmarionette化

By: Jackie – CC BY 2.0 目次1 Marionette.js2 インストール3 Application4 gulpfile.coffee5 ItemView6 Coll …

Electron+Browserify(debowerify)+jQueryUi

By: Wilson Hui – CC BY 2.0 目次1 bower install2 browserify(debowerify)3 require4 jQueryUIをMarion …

Electronのアプリケーションメニューからセーブダイアログを出してファイルを保存

By: Jean-Pierre Dalbéra – CC BY 2.0 目次1 はじめに2 require3 メニュー4 gulpfile.coffee5 できた はじめに 今後は、Ele …